Lync Sorted: Configure SNOM PA1 for Lync 2010

5
3192

Lync Sorted: Configure SNOM PA1 for Lync 2010: SNOM PA1 is a really easy to configure device that works out of the box with Lync as a PA system. What you will need:- The UC Edition of …

 

5 COMMENTS

  1. Hey Andrew
    Just trying to get one of the SNOM PA 1 going but having some issues with it. Followed your stuff in regard to this but cant get it working. Error I am getting is Registration failed with some of the logs

    Oct 14 14:46:23 [ERROR ] SIP: Registrar forbes.intercom@ceresseeds.com.au timed out
    Oct 14 14:46:23 [NOTICE] SIP: Registration Metrics failed
    Oct 14 14:47:17 [WARN ] SIP: transaction_timeout udp: 1000005 (32000)
    Oct 14 14:47:17 [ERROR ] SIP: transport error: 1000005 -> udp:10.150.1.4:5060
    Oct 14 14:47:17 [NOTICE] SIP: Add dirty host: udp:10.150.1.4:5060 (0 sec)
    Oct 14 14:47:31 [NOTICE] PHN: TPL: Socket 46 idle/connect timeout
    Oct 14 14:47:50 [WARN ] SIP: transaction_timeout udp: 1000005 (32000)
    Oct 14 14:47:50 [ERROR ] SIP: transport error: 1000005 -> udp:10.154.89.4:5060
    Oct 14 14:47:50 [NOTICE] SIP: Add dirty host: udp:10.154.89.4:5060 (0 sec)
    Oct 14 14:47:50 [WARN ] SIP: transaction_timeout udp: 1000005 (32500)
    Oct 14 14:47:50 [ERROR ] SIP: transport error: 1000005 -> udp:10.153.2.4:5060
    Oct 14 14:47:50 [NOTICE] SIP: Add dirty host: udp:10.153.2.4:5060 (0 sec)
    Oct 14 14:47:50 [ERROR ] SIP: request 1000005 destination invalid udp:10.153.2.4:5060 d17c932b28743f6a9069ae5ea1f4717
    Oct 14 14:47:50 [NOTICE] SIP: final transport error: 1000005 -> udp:10.153.2.4:5060
    Oct 14 14:47:50 [ERROR ] SIP: transport error 1000005: generating fake 599
    Oct 14 14:47:50 [ERROR ] SIP: Registrar forbes.intercom@ceresseeds.com.au timed out
    Oct 14 14:47:54 [NOTICE] CFG: Parameter ip_adr_v6 not found
    Oct 14 14:48:04 [NOTICE] PHN: TPL: Socket 50 idle/connect timeout

    Any guidance would be appreciated. Hope you are all good cheers John

  2. Thanks for the response. Yes installed UC edition without any issues. I was surprised to see it set with UDP as well. Can certainly change the setting to TCP. And yes followed your stuff as well. I sort of think there are firewall issues going on as well.

  3. Changed a few things and getting a better result as getting a SIP issue so now talking to the right server etc.

    Error in logs are :
    Oct 15 12:55:26 [WARN ] PHN: Could not resolve host >ceresseeds.com.au<
    Oct 15 12:55:26 [WARN ] TLS: Certificate verification omitted. TLS authentication is disabled!
    Oct 15 12:55:27 [NOTICE] CFG: Std-Settings stored
    Oct 15 12:55:32 [ERROR ] PHN: Dispatcher::SendRequest: NTLM credentials for identity 1 invalid
    Oct 15 12:55:32 [ERROR ] PHN: Dispatcher::SendRequest: No credentials set for identity 1
    Oct 15 12:55:32 [ERROR ] SIP: Challenge: Unknown scheme Kerberos
    Oct 15 12:55:32 [ERROR ] SIP: Challenge: Unknown scheme Kerberos
    Oct 15 12:55:32 [CRITIC] SIP: Registrar forbes.intercom@ceresseeds.com.au refused with code 401
    Oct 15 12:55:32 [CRITIC] SIP: Will not try to reregister because login credentials were rejected by Lync!

    Tested the login no problems with that it works from a Skype client.
    SIP Trace
    SIP/2.0 401 Unauthorized
    Date: Tue, 15 Oct 2019 01:55:32 GMT
    WWW-Authenticate: NTLM realm="SIP Communications Service", targetname="SVR-AUSFBFE-001.ceresseeds.local", version=4
    WWW-Authenticate: Kerberos realm="SIP Communications Service", targetname="sip/SVR-AUSFBFE-001.ceresseeds.local", version=4
    WWW-Authenticate: TLS-DSK realm="SIP Communications Service", targetname="SVR-AUSFBFE-001.ceresseeds.local", version=4, sts-uri="https://svr-ausfbfe-001.ceresseeds.local:443/CertProv/CertProvisioningService.svc&quot;
    From: "Forbes PA Speaker" ;tag=m37z0m7n2m;epid=0004138D4C8001
    To: “Forbes PA Speaker” ;tag=195AF2C412E096B872D44CF22534239A
    Call-ID: fb1f2e4b2d634b69890d31688307a779
    CSeq: 4 REGISTER
    Via: SIP/2.0/TLS 10.153.2.138:2272;branch=z9hG4bK-5juu8glmh8pv;rport;ms-received-port=2272;ms-received-cid=3BF9C00
    ms-diagnostics: 1000;reason=”Final handshake failed”;HRESULT=”0xC3E93EC3(SIP_E_AUTH_UNAUTHORIZED)”;source=”SVR-AUSFBFE-001.ceresseeds.local”
    ms-telemetry-id: C798C967-64AB-5C85-B8CD-43D284168864
    Server: RTC/7.0
    Content-Length: 0

    Very frustrating as it seems most settings are in line with your stuff

    • These 2 lines look like issues I’d investigate further:
      Oct 15 12:55:26 [WARN ] PHN: Could not resolve host >ceresseeds.com.au< Oct 15 12:55:26 [WARN ] TLS: Certificate verification omitted. TLS authentication is disabled! DNS might not be setup correctly for the domain. Also I'd say that TLS will be required so that might need to be enabled on the phone. Also since the firmware is so old, your PKI infrastructure may be too modern/secure for the phone to handle.

LEAVE A REPLY

Please enter your comment!
Please enter your name here